T4 Web Editor’s Manual
Texas Woman’s University

webteamrequest@twu.edu

Revised 2/6/2017
# Contents

What is T4? ......................................................................................................................... 3
Logging in ............................................................................................................................ 3

Site structure .......................................................................................................................... 4
  Home section ......................................................................................................................... 4
  Subsections ............................................................................................................................ 4
  Branches ................................................................................................................................ 5

Pages (Sections) ..................................................................................................................... 6
  Creating a new section ........................................................................................................... 6
  Metadata ................................................................................................................................. 6
  Hiding a section ....................................................................................................................... 7

Linking to an external URL from the main navigation ......................................................... 7
Rearranging subsections .......................................................................................................... 9
Moving a section ...................................................................................................................... 12
Deleting a section ................................................................................................................... 13
Restoring a section .................................................................................................................. 13

Content .................................................................................................................................... 14
  Adding content ....................................................................................................................... 15
    Text with Image .................................................................................................................... 16
    Text ...................................................................................................................................... 19
  Image.................................................................................................................................... 19
  Video .................................................................................................................................... 19
  Teaser .................................................................................................................................... 21
  Pull Quote ............................................................................................................................... 22
  Columns ................................................................................................................................. 23
  Banner .................................................................................................................................... 23

Text editor ............................................................................................................................... 23
  Basic formatting .................................................................................................................... 23
  Headings ............................................................................................................................... 23
  Tables .................................................................................................................................... 25

Linking to an existing T4 section ............................................................................................ 27
Linking to an external URL from the text editor ................................................................. 28
Linking to a document (Word, PDF, etc.) ............................................................................. 28

Rearranging content .............................................................................................................. 32
Moving content ....................................................................................................................... 32
Deleting content ....................................................................................................................... 34
What is T4?

Terminal Four (T4) is a content management system (CMS) that allows you to manage your website. The software is web-based and accessible through your web browser (Internet Explorer, Firefox, Chrome, or Safari). If you are not within the TWU network, you will need to use VPN remote access.

Logging in

Open a web browser and type the following URL into the address bar: http://t4.twu.edu/terminalfour/

At the login window, type in your Portal username and password which is the same as what you use when logging onto your office computer.
Site structure

The Site Structure shows the pages that make up a website. T4 calls pages sections.

Home section

The home section of a site is the very top section. The remaining sections are indented below it.

Subsections

Clicking the plus sign [+] next to a section reveals the subsections below. The icon then becomes a minus sign [-] that can be clicked again to close it.

This first set of subsections shows up as the main navigation of your site.
Main navigation items may be:

- The home section link (chain icon).

- A visible T4 section (solid folder).

- An external link (box with an arrow).

Hidden T4 sections (clear folders) do not appear in the navigation. The hidden sections with names in lower-case (contact-information, date-published, department-footer, etc.) are part of your template and should be left alone.

**Branches**

A section with a plus sign and all sections below it make up a **branch** of the Site Structure. Here is a branch beginning with the Graduate Programs page. A branch can begin with any section, no matter its level in the Site Structure.
Pages (Sections)

Creating a new section

Click the blue Actions button next to a section to create a subsection below it. Next, select Create section from the drop-down menu. Here, we are creating a subsection of Graduate Programs called Doctorate (Ph.D.).

Enter the section name.

Metadata

Search engines use metadata to locate and describe pages. You should add metadata to all new sections, but it is especially important for the sections in your main navigation.

Click the More dropdown and select Metadata.

In the description field, type a sentence or two that describes the page using words a user might enter into a search engine. Then, click the Save changes button. Meta keywords are no longer useful, so you can leave the keywords field blank.
Hiding a section

By default, new sections show as links in the navigation. To hide a section from the navigation, uncheck the box called Show in navigation. This is useful for creating sections that you plan to link from the content of a page, but not the main navigation.

To save your new section, click the Save changes button at the bottom of the screen.

Linking to an external URL from the main navigation

Use an external URL (external web address) for links to pages not in the T4 system. This includes RedDot pages.

Click the blue Actions button next to the top-level section and select Create Section.
Type the **Name** of the new link.

Check the **Mark as link section** box.
Click the **Details** tab.

Lastly, click the radio button for **External URL**, paste the URL in the Link URL field, and click the **Save changes** button.

**Rearranging subsections**

New subsections appear underneath existing ones.
To change the order of subsections, select the **Actions** button for the top-level section just above. Then, click **Edit section** to reorder its subsections.

Select the **More** tab then click **Subsections**.

If you can’t see all entries on one screen, increase the number by increasing the **Display records** number.
Click the cross icon and hold the mouse button for the entry you want to rearrange. Then, drag and drop the entry into its new place.

Click the Save changes button.

You will then see the link in its new location.
Moving a section

To move a section to a different location in the site structure, click the Edit button next to the page you want to move. Then, click Move Section.

On the Move Section screen, you will see a view of the entire TWU site structure. Scroll and click the destination section. The section you are moving will become a subsection of it. Look at the Move to path at the bottom of the screen to make sure your destination section appears at the end. Click the Move Selected Section button.
You will see your page has moved underneath the destination section.

Deleting a section

Click on the Actions menu next to the section and select Delete.

The section listing will be colored red and its Status will change to Inactive.

Deleted sections, all of their subsections, and all content on those sections are purged completely from the system every Friday at 4:00 pm. Please keep backup copies of your content.

Restoring a section

To restore a deleted section that has not yet been purged, click on the Actions menu and select Edit section. Change the Status field to Approved.
## Content

Add content to a section using content types.

<table>
<thead>
<tr>
<th><strong>Text with Image</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Used for text with an image that can be floated left or right.</td>
</tr>
</tbody>
</table>

*Learn all about lichens*

A lichen is a composite organism that arises from algae or cyanobacteria (or both) living among filaments of a fungus in a commensal relationship. The combined life form has properties that are very different from the properties of its component organisms. Lichens come in many colors, sizes, and forms. The properties are sometimes plant-like, but lichens are not plants. Lichens may have thin, leaf-like structures (fruticose), flat leaf-like structures (foliose), cushions that lie on the surface like pebbles (crustose), or other growth forms. A mucronate lichen is a lichen that either has a hard or deeply convex upper lip of the lichen, and all other lichens are termed microlichens.

* `Macro` and `micro` do not refer to size, but to the growth form. Common names for lichens may contain the word *moss* (e.g., *Brooke’s moss* or *Harland moss*), and lichens may superficially look like and grow with mosses, but lichens are not related to mosses or any plant. Lichens do not have roots that absorb water and nutrients as plants do, but like plants they produce their own food by photosynthesis using sunlight energy from carbon dioxide, water and nutrients in their environment. When they grow on plants, they do not live as parasites and only use the plants as a substrate.

<table>
<thead>
<tr>
<th><strong>Text</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Used for text only. If you need an image to accompany the text, use the Text with Image content type instead.</td>
</tr>
</tbody>
</table>

| **Environmental Studies at TWU** |
| **We offer bachelor's (B.A., B.S.), master's (M.S.), and doctoral degrees (Ph.D.); Choose TWU for our** |
| **- Nationally-recognized faculty** |
| **- State-of-the-art labs** |
| **- Field-based practice** |

<table>
<thead>
<tr>
<th><strong>Image</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Used for an image only. If you need text to accompany the image, use the Text with Image content type instead.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Takakkaw Falls field workers witnesses an amazing rainbow</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>[TakakkawFalls edit](<a href="https://commons.wikimedia.org/wiki/File:TakakkawFalls2">https://commons.wikimedia.org/wiki/File:TakakkawFalls2</a> edit.jpg)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Video</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Used to embed a video from a video-hosting service like YouTube, Vimeo, or TED.</td>
</tr>
</tbody>
</table>

| **Why study Environmental Studies at TWU** |
| **Why I Chose to Study Environmental Studies** |

<table>
<thead>
<tr>
<th><strong>Teaser</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Earthwise Gardens now accepting volunteers</td>
</tr>
</tbody>
</table>

| **Earthwise Gardens now accepting volunteers** |
| **Denton's Earthwise Gardens is now accepting volunteer farmers for Fall 2019. Workers get hands-on experience in sowing, growing, and harvesting sustainable crops that can handle the Texas heat. [Read More >>](https://example.com)** |

<table>
<thead>
<tr>
<th><strong>Pull Quote</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;I love TWU. It’s the best ever and I will attend TWU forever! Love! Love! Love it! I’m going to send all of my friends here and pay their way. TWU is exceptionally exceptional. It's excellence par excellence. Thanks, TWU, for being my hero. — Jane Pioneer&quot;</td>
</tr>
</tbody>
</table>
Adding content

To add a content type to a section, click the **Actions** button for that section and click **Create content**.

Choose a **content type** by clicking its name.
Text with Image

Enter the Name of the piece of content. This is the system name used for identifying and searching within T4. It does not appear on the live site. Optionally, enter a Heading that will appear above the text and image.

Paste or type your text into the Body Text field. If pasting from Word, we recommended you first click the Edit dropdown menu and click Paste as text. This will clean up any problematic hidden code, but you may have to do some reformatting.

Use keyboard shortcuts Ctrl + V or Command + V to paste your text.

Crop (if needed) and resize your image according to the sizes in the Appendix. If you don’t have an image editor like Photoshop, you can use the free online editor Pixlr Express at https://www.pixlr.com/express/

Click the Select Media button to open the media library.
Open the **Images** folder by clicking the plus sign [+]. Then, click the link for your department’s folder.

Click the Add Media button.

Drag and drop an image from your computer into the **Media file** area, or click the area to browse for an image. Your file name should use dashes instead of spaces (example: red-oak-tree.jpg).

Type the system **Name** of the image and type an image **Description** (optional) that will appear only in the media library.

Click the drop-down menu triangle icon on the Save changes button and choose **Save & select**.
To make the image accessible, you must type alternative text for image in the **Image Alt Text** field.

Change the image position to appear to the left or right of the **Body Text** by clicking the radio button for either **Align Left** or **Align Right**.

Optionally, you may add a caption just below the image by checking the **Has Caption?** radio button and typing in the **Image Caption Text** field. Captions are useful for identifying people or for photo credits. Click **Save and approve** from the Save changes dropdown menu to create the content type.
Text

The Text content type works like the Text with Image content type, except that there is no image picker. It is used for text only. If you need an image to accompany the text, use the Text with Image content type instead.

Image

The Image content type works like Text with Image content type, except that there is no text editor. It is used for a large image that may span the entire width of the body area. See the appendix for image sizes.

Video

Embedding a video player with controls is often preferable to simply providing a link to a video. Before you embed or link to a video, you must make it accessible by providing closed captioning within the video-hosting service using the method of your choice (an employee typing it, a transcription service, etc.).

Video-hosting services differ in how they provide embed code.

**Embedding from YouTube**

Click Share → Embed → SHOW MORE.

Highlight and copy the Embed code, select the video size, then uncheck the box that reads Show suggested videos when the video finishes.
Embedding from Vimeo

Click the Share button (paper airplane icon).

Highlight and copy the Embed code, type in the video Size, and only check the box that reads Show text link underneath this video.
Once you have the embed code, create a Video content type and enter the **Name**. This is the system name used for identifying and searching within T4. It does not appear on the live site. Optionally, enter a **Heading** to appear above the video.

Paste the embed code into the Embed Code field.

Depending on the video, select the radio button for either the 16:9 (widescreen) or 4:3 (full screen) aspect ratio.

Click **Save and approve** from the Save changes dropdown menu to create the content type.

**Teaser**

Enter the system Name, Headline, and Teaser text.
Optionally, you can add a 100px x 100px Image with Image Alt Text using the steps mentioned above under Text with Image. The image will appear to the left of your teaser text.

Paste the Link to the page with the full story. Then, click the Save changes button and select Save and approve.

Pull Quote

Type the Name of the piece of content, enter the quotation in the Quotation field, and enter the person’s name in the Person Quoted field.
Optionally, you can add a 100px x 100px Image with Image Alt Text using the steps mentioned above under Text with Image. The image will appear to the right of your pull quote. Click the Save changes dropdown and choose Save and approve.

Columns

The body area of a page can be divided into multiple columns using column content types. For assistance with adding multiple columns, please contact the TWU Web Team at webteamrequest@twu.edu

Banner

Banner images are used to indicate a home page of a website. For help with your banner, please contact the TWU Web Team at webteamrequest@twu.edu

Text editor

Basic formatting

Basic formatting commands such as bold, italics, bulleted or numbered lists, and indentation are located at the bottom of the toolbar.

Headings

Use headings to break up long passages of text into easy-to-scan topics and subtopics. From the Format dropdown menu, select Formats → Headings → Heading 2, 3, etc. (Heading 1 is reserved for the page name).
To change a heading back to a paragraph, select Format → Formats → Blocks → Paragraph.
Tables

Create and name a piece of content using the Text content type. In the Body Text area, chose the **Table** tab, select Insert table. Highlight and click the grid to draw a table based on the number of cells you want.

Type your values into the table cells. If you have trouble selecting the cells, use Tab on your keyboard to cycle through them.

Highlight the top row of cells. This will become your table header.

Select Table → Row → Row properties.
Select Row type → Header.

Now, go into the source code.

Replace the line `<table>` with one of the following:

**Standard Table**
In the source code, replace `<table>` with `<table class="table">`.

**Striped Table**
In the source code, replace `<table>` with `<table class="table table-striped">`.

**Bordered Table with Hover**
In the source code, replace `<table>` with `<table class="table table-bordered table-hover">`.

In the example below, we are making a striped table.

**Source code**

```
<table>
  <thead>
    <tr>
      <td>Animal Name</td>
      <td>Number of Legs</td>
      <td>Furry or Not?</td>
      <td>Suitable as a Pet</td>
    </tr>
  </thead>
  <tbody>
    <tr>
      <td>Tiger</td>
      <td>4</td>
      <td>yes</td>
      <td>no</td>
    </tr>
    <tr>
      <td>Pot-belly Pig</td>
      <td>4</td>
      <td>no</td>
      <td>yes</td>
    </tr>
  </tbody>
</table>
```
Click **OK** to save the code. Then, click **Save and approve**.

**Linking to an existing T4 section**

To link to a section, you must add the section beforehand using the steps mentioned above under **Creating new pages**. You can name the link using one of two different methods.

**Let T4 create the link name based on the section name**

To let T4 create the link name, simply place your cursor where you want the link. You do not need to type anything. The link name will be generated based on the T4 section name.

**Manually type the link name**

Type, then highlight, the text you want to become the link.

After choosing one of these two methods, click the chain icon (not the broken chain icon) and select **Insert section link** from the drop-down menu.

Click the section you want to link to from the site tree. You may have to open a folder or two if you are linking to a deep subsection.

Scroll to the bottom of the screen and look at the path to the Selected: section and make sure your destination section is listed at the end. Finally, click the **Select section** button.
Linking to an external URL from the text editor

To create external links within the text editor, highlight the text you want to become the link. Click the **chain icon** and select **Insert/edit external link** from the drop-down menu.

![Insert/edit external link icon]

Paste the external link into the **Url** field. Then, click the **OK** button.

![Insert link dialog box]

**Linking to a document (Word, PDF, etc.)**

To create a link to a document (Word, PDF, etc.), place your cursor where you want the link and click on the **media icon**.

![Media icon]

Open the documents folder and click the link for your department’s subfolder. Then, click the **Add media** button at the top of the screen.
Click on the Media file field to browse to your file or simply drag and drop your file into the field. T4 will automatically determine the Media type.

Enter a Name for the item. This will be the system name for the media library as well as the text that appears on the link. Click the dropdown menu and choose Save & select.
The document link will appear in the text editor. Press the space bar and type the file format such as (PDF), (Word), or (PPT) in brackets or parentheses. This lets users know the link isn’t just a webpage.

To change the document link text, change the document Name in the Media library. To go directly into the Media library, click Content on the T4 main menu then click Media library.

Click your department’s documents folder to open it and view the documents within.
Click **Actions** then **Edit** for the document you want to rename.

Type a new **Name** and click the **Save changes** button.
Rearranging content

Click the cross icon and hold the mouse button for the piece you want to move. Then, drag and drop the piece into its new place.

Once the content piece is where you want it, save the order by clicking the **Save changes** button.

Moving content

To move a piece of content, select **Actions** then **Edit content** for the section that contains the content.
For the piece of content, click the **Actions** dropdown menu and select **Move content**.

Scroll to find the destination section then click it. Look at the **Move to** path at the bottom of the screen to make sure your destination section appears at the end. Click the **Move selected content** button.
Deleting content

Click on the **Actions** menu next to either the content and select **Delete**. The content listing will be colored red and its Status will change to **Inactive**.

Deleted content is purged completely from the system every Friday at 4:00 pm. Please keep backup copies of your content.

Restoring content

To restore deleted content that has not yet been purged, click on the **Actions** menu and select **Edit**.

Click the **Save changes** dropdown then select **Save and approve**.
Workflow

Setting a section to pending

Set a section to Pending if you do not want it or any sections below it to publish. Pending sections will not be purged weekly.

Click on the Actions menu and select **Edit section**. Change the **Status** field to Pending.

![General section details]

Click the **Save changes** button. The pending section will be colored orange.

![Advanced settings]

When you are ready for the section and the sections below it to publish, change the **Status** back to Approved.

Previewing

Preview your work to get an idea how it will appear on the live website by clicking **Actions** then selecting **Preview section** from a given section. You can also select **Actions → Preview** from an individual piece of content within a section to preview that entire section.
Click the radio button for the channel called **WWWTest**, then, click the **Preview** button.

**Publishing to the test server**

Publish to the test server (wwtest) before publishing to the live server (www). To publish your entire site at once, click the Actions button for the top page of your site. Select Publish branch from the dropdown menu.
Alternately, you can publish one section at a time by choosing Publish section from the Actions menu for a given section.

Select the radio button for WWWTEST and click the confirm button. Your site will take about 2-3 minutes to publish.

Open a new tab and go to the home page of your site. Type the word “test” just after the www part of the web address and press enter or return on your keyboard.
Check your work using as many web browsers as you have available. Make sure links work and that the pages and content pieces do not appear broken. If you see any problems, please contact the Web Team for support before publishing to the live server.

Publishing to the live server

If your pages work and look ok, it’s time to publish to the live server (www).

Follow the steps for publishing, but choose the WWW server instead.
Double-check your work on the live site by deleting the “test” part of the web address and pressing enter or return.

Contacting the Web Team

If you have any questions, please contact the TWU Web Team at webteamrequest@twu.edu
Appendix

Glossary

Alternative Text - Text placed behind the code to describe image content. Alternative text is read by screen reader software to assist users with disabilities, but it does not display on the visible page.

Branch - The part of the file tree consisting of a department home page (section) followed by its back pages (subsections)

Content Type - A system piece chosen to create webpage (section) content

Document - A file such as Word, PDF, or XLS that is linked within a webpage. Original documents must be added to the media library in order to create the link.

Heading - Text that is formatted to indicate a division of page content by topic

Image - A photo or graphic file displayed on a webpage. Photos are usually saved in the .jpg or .png file format, while graphics are usually saved as .gif. An image should be saved at a resolution of 72 dpi for display on the Web. An image must be added to the media library in order to display on the page.

Link Section - A section that links to an external web address/URL

Name - A system name used by T4 for a section or piece of content. The name does not display on the published site.

Media Library - The document and image storage area. Any original documents or images must be stored in the media library before being placed in a piece of content.

Section - A single webpage, usually a page created in the T4 system

Site Structure – A tree structure representing all interconnected pages within a website

Sub-sections – Back pages of a section higher up in the Site Structure

Text Editor - A form field to type/paste and format text and image content.

Image sizes

All images for the Web should use a resolution of 72dpi. Image sizes are listed below in pixels.

- 2-Columns (6-6): 409px W - 409px W
- 2-Columns (4-8): 262px W - 555px W
- 3-Columns (3-6-3): 189px W - 409px W - 189px W
- 3-Columns (4-4-4): 262px W - 262px W - 262px W
- 4-Columns (3-3-3-3): 189px W -189px W -189px W -189px W
- Banner: 848px x 350px (W x H)
- Image:
  - landscape orientation: 848px max W
  - portrait orientation: 385px x 600px (W x H)
- Pull quote: 100px x 100px (W x H)
- Teaser: 100px x 100px (W x H)
- Text with Image: 718px W Height may vary.